import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\d{2}\\/\\d{2}\\/\\d{2} )\\S+";
final String string = "SOMEDATA .test 01/45/12 2.50 THIS IS DATA\n"
+ "SOMEDATA .test 01/45/12 2500 THIS IS DATA";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}