re = /(?<=\d{2}\/\d{2}\/\d{2} )\S+/
str = 'SOMEDATA .test 01/45/12 2.50 THIS IS DATA
SOMEDATA .test 01/45/12 2500 THIS IS DATA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end