using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'[^']*'(*SKIP)(*F)|,";
string input = @"@include (\'file_to_load\',\'param1,something\',[\'elem\'=>\'also, a comma\']])";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}