$re = '/\'[^\']*\'(*SKIP)(*F)|,/';
$str = '@include (\\\'file_to_load\\\',\\\'param1,something\\\',[\\\'elem\\\'=>\\\'also, a comma\\\']])';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);