package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\( MI - [OF] - [0-9]* \)`)
var str = `( MI - O - 30157 )
( MI - O - 30157Z )
( MI - O - 301576 )
( MI - F - 20157 )
(asd)
( asfdg )
( MI - A - 235 ) `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}