$re = '/\( MI - [OF] - [0-9]* \)/m';
$str = '( MI - O - 30157 )
( MI - O - 30157Z )
( MI - O - 301576 )
( MI - F - 20157 )
(asd)
( asfdg )
( MI - A - 235 ) ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);