#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^(\d\d\/\d\d\/\d\d\d\d.*?)(?=^^\d\d\/\d\d\/\d\d\d\d|\Z)"
Local $sString = "06/01/2016, 10:40 pm - abcde" & @CRLF & _
"07/01/2016, 12:04 pm - abcde" & @CRLF & _
"07/01/2016, 12:05 pm - abcde" & @CRLF & _
"07/01/2016, 12:05 pm - abcde" & @CRLF & _
"07/01/2016, 6:14 pm - abcde" & @CRLF & _
"" & @CRLF & _
"fghe" & @CRLF & _
"07/01/2016, 6:20 pm - abcde" & @CRLF & _
"07/01/2016, 7:58 pm - abcde" & @CRLF & _
"" & @CRLF & _
"fghe" & @CRLF & _
"" & @CRLF & _
"ijkl" & @CRLF & _
"07/01/2016, 7:58 pm - abcde"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")