# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\d\d\/\d\d\/\d\d\d\d.*?)(?=^^\d\d\/\d\d\/\d\d\d\d|\Z)"
test_str = ("06/01/2016, 10:40 pm - abcde\n"
"07/01/2016, 12:04 pm - abcde\n"
"07/01/2016, 12:05 pm - abcde\n"
"07/01/2016, 12:05 pm - abcde\n"
"07/01/2016, 6:14 pm - abcde\n\n"
"fghe\n"
"07/01/2016, 6:20 pm - abcde\n"
"07/01/2016, 7:58 pm - abcde\n\n"
"fghe\n\n"
"ijkl\n"
"07/01/2016, 7:58 pm - abcde")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.