$re = '/\!?empty\(([^)]+)\)/m';
$str = '!empty($act_s[10])
empty($act_s[10])
empty($act_s[10])
empty($Znachenie)
empty($Znachenie[$luboy_Dlinny])';
$subst = "${1}==\"\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;