import Foundation
let pattern = #"\!?empty\(([^)]+)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
!empty($act_s[10])
empty($act_s[10])
empty($act_s[10])
empty($Znachenie)
empty($Znachenie[$luboy_Dlinny])
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${1}=="""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)