#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?=ra\/[0-9]{4}\/[0-9]+\/[0-9]{2}\/[0-9]+\/\Qimage(2).jpg\E).+$)"
Local $sString = "http://localhost:8080/ra/2015/10160/11/115500/image(2).jpg""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")