using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-9a-zA-Z~@#$^*()_+=[\]{}|\\,.?: -'.\s]{2,20}$";
string input = @"abjc
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}