$re = '/^[0-9a-zA-Z~@#$^*()_+=[\]{}|\\\\,.?: -\'.\s]{2,20}$/';
$str = 'abjc
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);