package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*?)\{\{.*\}\}.*(\{\{.*\}\})`)
var str = `хай {{ Чао {{привет}} лол}} {{ ку }}
хай {{ Чао {{привет}} лол}} {{ ку }},`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}