$re = '/(.*?)\{\{.*\}\}.*(\{\{.*\}\})/m';
$str = 'хай {{ Чао {{привет}} лол}} {{ ку }}
хай {{ Чао {{привет}} лол}} {{ ку }},';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);