$re = '`^Mr\.Robot\.S04.+(VOSTFR|SUBFRENCH).+(720p).+(HDTV|WEB-DL|WEBRip).+`m';
$str = 'Mr.Robot.S04E04.VOSTFR.720p.HDTV.x264-WEEDS.mkv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);