re = /^Mr\.Robot\.S04.+(VOSTFR|SUBFRENCH).+(720p).+(HDTV|WEB-DL|WEBRip).+/m
str = 'Mr.Robot.S04E04.VOSTFR.720p.HDTV.x264-WEEDS.mkv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end