using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Created '(.+)'";
string input = @"VERBOSE: Created 'C:\test\foo.txt'.
VERBOSE: Created 'C:\test\bar.txt'.";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}