re = /Created '(.+)'/mi
str = 'VERBOSE: Created \'C:\\test\\foo.txt\'.
VERBOSE: Created \'C:\\test\\bar.txt\'.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end