const regex = /^(("".+?"")|([0-9a-zA-Z](((\.(?!\.))|([-!#\$%&'\*\+\/=\?\^`\{\}\|~\w]))*[0-9a-zA-Z])*))@([0-9a-zA-Z][-\w]*[0-9a-zA-Z]\.)+[a-zA-Z]{2,9}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(("".+?"")|([0-9a-zA-Z](((\\.(?!\\.))|([-!#\\$%&\'\\*\\+\\\/=\\?\\^`\\{\\}\\|~\\w]))*[0-9a-zA-Z])*))@([0-9a-zA-Z][-\\w]*[0-9a-zA-Z]\\.)+[a-zA-Z]{2,9}$', '')
const str = `abcd1090ihavenoidea.what.going.wrong.here`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}