$re = '/^(("".+?"")|([0-9a-zA-Z](((\.(?!\.))|([-!#\$%&\'\*\+\/=\?\^`\{\}\|~\w]))*[0-9a-zA-Z])*))@([0-9a-zA-Z][-\w]*[0-9a-zA-Z]\.)+[a-zA-Z]{2,9}$/';
$str = 'abcd1090ihavenoidea.what.going.wrong.here';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);