const regex = /[\W]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\W]', 'gm')
const str = `s/Information Needed1-s84102-p306`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);