$re = '/[\W]/m';
$str = 's/Information Needed1-s84102-p306';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;