$re = '/(^не|\sне|неудобно).*(удобно)/m';
$str = 'мне не слишком удобно
не удобно
нет, не удобно
неудобно
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);