re = /(^не|\sне|неудобно).*(удобно)/m
str = 'мне не слишком удобно
не удобно
нет, не удобно
неудобно
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end