const regex = new RegExp('\\b\\d{1,2}\\s\\D+\\s(?:20|19)\\d\\d\\b', 'gm')
const str = `I'm trying to catch all dates with the form 15 Jun 1985. or 1 jan 1999 or 31 dec 2020`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}