use strict;
my $str = 'I\'m trying to catch all dates with the form 15 Jun 1985. or 1 jan 1999 or 31 dec 2020';
my $regex = qr/\b\d{1,2}\s\D+\s(?:20|19)\d\d\b/mp;
if ( $str =~ /$regex/g ) {
  print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
  # print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
  # print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}