# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".+\(.+ (.+)\).*"
test_str = ("LS388 (145/70 R13 71T)\n"
"LS388 (155/65 R13 73T)\n"
"LS388 (155/65 R14 75T)\n"
"4-Seasons (155/65 R14 75T)\n"
"CT6 (155/70 R12 104N) 72EE\n"
"LS388 (155/70 R13 75T)\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.