$re = '/<h4>В главных ролях:<\/h4>\s*<ul>(.*)<\/ul>/';
$str = '<div id="actorList" class="clearfix actorListbg">
<h4>В главных ролях:</h4>
<ul><li itemprop="actors"><a href="/name/27959/">Альберт Брукс</a></li><li itemprop="actors"><a href="/name/20162/">Эллен ДеДженерес</a></li><li itemprop="actors"><a href="/name/14715/">Александр Гоулд</a></li><li itemprop="actors"><a href="/name/9274/">Уиллем Дефо</a></li><li itemprop="actors"><a href="/name/6754/">Эллисон Дженни</a></li><li itemprop="actors"><a href="/name/23960/">Джо Рэнфт</a></li><li itemprop="actors"><a href="/name/24683/">Джеффри Раш</a></li><li itemprop="actors"><a href="/name/10781/">Элизабет Перкинс</a></li><li itemprop="actors"><a href="/name/11215/">Эрик Бана</a></li><li itemprop="actors"><a href="/name/23951/">Эндрю Стэнтон</a></li><li itemprop="actors"><a href="/film/7908/cast/">...</a></li></ul>
<h4>Роли дублировали:</h4>
<ul><li itemprop="actors"><a href="/name/298467/">Ян Цапник</a></li><li itemprop="actors"><a href="/name/477449/">Елена Шульман</a></li><li itemprop="actors"><a href="/name/1660135/">Федор Машанов</a></li><li itemprop="actors"><a href="/name/273210/">Виктор Костецкий</a></li><li itemprop="actors"><a href="/name/37388/">Мария Кузнецова</a></li><li itemprop="actors"><a href="/film/7908/cast/">...</a></li></ul>
<h4><a href="/film/7908/cast/">показать всех</a> »</h4>
</div>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);