# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<h4>В главных ролях:<\/h4>\s*<ul>(.*)<\/ul>"
test_str = ("<div id=\"actorList\" class=\"clearfix actorListbg\">\n"
" \n"
" \n"
" \n"
" <h4>В главных ролях:</h4>\n"
" <ul><li itemprop=\"actors\"><a href=\"/name/27959/\">Альберт Брукс</a></li><li itemprop=\"actors\"><a href=\"/name/20162/\">Эллен ДеДженерес</a></li><li itemprop=\"actors\"><a href=\"/name/14715/\">Александр Гоулд</a></li><li itemprop=\"actors\"><a href=\"/name/9274/\">Уиллем Дефо</a></li><li itemprop=\"actors\"><a href=\"/name/6754/\">Эллисон Дженни</a></li><li itemprop=\"actors\"><a href=\"/name/23960/\">Джо Рэнфт</a></li><li itemprop=\"actors\"><a href=\"/name/24683/\">Джеффри Раш</a></li><li itemprop=\"actors\"><a href=\"/name/10781/\">Элизабет Перкинс</a></li><li itemprop=\"actors\"><a href=\"/name/11215/\">Эрик Бана</a></li><li itemprop=\"actors\"><a href=\"/name/23951/\">Эндрю Стэнтон</a></li><li itemprop=\"actors\"><a href=\"/film/7908/cast/\">...</a></li></ul>\n"
" \n"
" \n"
" <h4>Роли дублировали:</h4>\n"
" <ul><li itemprop=\"actors\"><a href=\"/name/298467/\">Ян Цапник</a></li><li itemprop=\"actors\"><a href=\"/name/477449/\">Елена Шульман</a></li><li itemprop=\"actors\"><a href=\"/name/1660135/\">Федор Машанов</a></li><li itemprop=\"actors\"><a href=\"/name/273210/\">Виктор Костецкий</a></li><li itemprop=\"actors\"><a href=\"/name/37388/\">Мария Кузнецова</a></li><li itemprop=\"actors\"><a href=\"/film/7908/cast/\">...</a></li></ul>\n"
" \n"
" <h4><a href=\"/film/7908/cast/\">показать всех</a> »</h4>\n"
" </div>")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.