import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*time:(.*?)\\s*host:([\\d\\.]{0,15})\\s*user:(.*?)\\s*forwardedfor:(.*?)\\s*req:(.*?)\\s*method:(.*?)\\s*uri:(.*?)\\s*protocol:(.*?)\\s*status:(\\d*)\\s*size:(\\d*)\\s*reqsize:(\\d*)\\s*referer:(.*?)\\s*ua:(.*?)\\s*vhost:(.*?)\\s*reqtime:([\\d\\.]*)\\s*cache:(.*?)\\s*apptime:(.*?)\\s*https:(.*?)\\s*session_id:(.*?)\\s*";
final String string = "time:27/Mar/2015:17:56:12 +0900 host:210.210.210.210 user:- forwardedfor:- req:- method:- uri:- protocol:- status:200 size:0 reqsize:0 referer:-ua:- vhost:www.web.com reqtime:59.992 cache:- apptime:- https: session_id: ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}