using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{5}(?:-d{4})?)$";
string input = @"3333 10TH ST., N. #201, WEST PALM BEACH FL 34103
3333 10TH ST., N. #201, WEST PALM BEACH, FL 34103";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}