package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{5}(?:-d{4})?)$`)
var str = `3333 10TH ST., N. #201, WEST PALM BEACH FL 34103
3333 10TH ST., N. #201, WEST PALM BEACH, FL 34103`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}