import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((http(s)?[:\\/\\/]{1,}))?([a-z0-9\\-]{1,}[.])([a-z0-9\\-]{1,}[.])?([a-z]{2,3})(.{1,})?";
final String string = "http://example.com\n\n"
+ "http://subdom.example.com\n\n"
+ "http://example.uk\n\n"
+ "https://example.com\n\n"
+ "https://subdom.example.com\n\n"
+ "https://example.uk\n\n"
+ "http://example.com/?query=butt\n\n"
+ "http://subdom.example.com/?query=butt\n\n"
+ "http://example.uk/?query=butt\n\n"
+ "https://example.com/?query=butt\n\n"
+ "https://subdom.example.com/?query=butt\n\n"
+ "https://example.uk/?query=butr\n\n"
+ "tasdfa .ss";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}