package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[^a-g]|^)m`)
var str = `m
am
hkjm
but do you really want to match any m's like these?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}