$re = '/(?:[^a-g]|^)m/m';
$str = 'm
am
hkjm
but do you really want to match any m\'s like these?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);