package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[^0-9]*[0-9][a-z]-(.*?)-[0-9]{1,3}.*$`)
var str = `us-east-1b-application-type-environment-138-10.domain.com`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}