$re = '/^[^0-9]*[0-9][a-z]-(.*?)-[0-9]{1,3}.*$/';
$str = 'us-east-1b-application-type-environment-138-10.domain.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);