#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "id="\d*".*<location id="2703">"
Local $sString = "<item id="42200027" xmlns="urn:microsoft-dynamics-nav/xmlports/WebStoreExportRemains"><locations><location id="2704"><rest_qty>0.00</rest_qty><expected_qty>0.00</expected_qty><expected_date/></location></locations></item><item id="42200028" xmlns="urn:microsoft-dynamics-nav/xmlports/WebStoreExportRemains"><locations><location id="2703"><rest_qty>0.00</rest_qty><expected_qty>0.00</expected_qty><expected_date/></location></locations></item><item id="42200029" xmlns="urn:microsoft-dynamics-nav/xmlports/WebStoreExportRemains"><locations><location id="2703"><rest_qty>0.00</rest_qty><expected_qty>0.00</expected_qty><expected_date/></location></locations></item><item id="42200030" xmlns="urn:microsoft-dynamics-nav/xmlports/WebStoreExportRemains"><locations><location id="2703"><rest_qty>0.00</rest_qty><expected_qty>0.00</expected_qty><expected_date/></location></locations></item><item id="42200031" xmlns="urn:microsoft-dynamics-nav/xmlports/WebStoreExportRemains"><locations><location id="2705"><rest_qty>0.00</rest_qty><expected_qty>0.00</expected_qty><expected_date/></location></locations></item><item id="42200032" xmlns="urn:microsof^Ct-dynamics-nav/xmlports/WebStoreExportRemains"><locations><location id="2703"><rest_qty>0.00</rest_qty><expected_qty>0.00</expected_qty><expected_date/></location></locations></item><item id="42200033" xmlns="urn:microsoft-dynamics-nav/xmlports/WebStoreExportRemains"><locations><location id="2703"><rest_qty>0.00</rest_qty><expected_qty>0.00</expected_qty><expected_date/></location></locations></item><item id="42200034" xmlns="urn:microsoft-dynamics-nav/xmlports/WebStoreExportRemains"><locations><location id="2703"><rest_qty>0.00</rest_qty><expected_qty>0.00</expected_qty><expected_date/></location></locations></item><item id="42200035" xmlns="urn:microsoft-dynamics-nav/xmlports/WebStoreExportRemains"><locations><location id="2703"><rest_qty>0.00</rest_qty><expected_qty>0.00</expected_qty><expected_date/></location></locations></item><item id="42200036" xmlns="urn:microsoft-dynamics-nav/xmlports/WebStoreExportRemains"><locations><location id="2703"><rest_qty>0.00</rest_qty><expected_qty>0.00</expected_qty><expected_date/></location></locations></item><item id="42200037" xmlns="urn:microsoft-dynamics-nav/xmlports/WebStoreExportRemains"><locations><location id="2703"><rest_qty>0.00</rest_qty><expected_qty>0.00</expected_qty><expected_date/></location></locations></item><item id="42200038" xmlns="urn:microsoft-dynamics-nav/xmlports/WebStoreExportRemains"><locations><location id="2703"><rest_qty>0.00</rest_qty><expected_qty>0.00</expected_qty><expected_date/></location></locations>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")