package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?\d+-\d+.*$`)
var str = `person/1234-5678-9123
person/123456789123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}