$re = '/^.*?\d+-\d+.*$/m';
$str = 'person/1234-5678-9123
person/123456789123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);