$re = '/^(https:|http:)?[\/](?![\/])(.*)/mi';
$str = 'https:/regex101.com
http:/regex101.com
https://regex101.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);