re = /^(https:|http:)?[\/](?![\/])(.*)/mi
str = 'https:/regex101.com
http:/regex101.com
https://regex101.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end