import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<delim>[^\\w\\n\"\\'])(?P<space> ?)(?P<quote>[\"\\'~]).*?(?P=quote)(?P=delim)";
final String string = "~File Type~,~DV Dealer ID~,~Delegate Dealer ID~,~DMS Type~,~Stock Number~,~Vehicle Type~,~Vehicle Status~,~Inventory Date~,~Purchase Date~,~Sold Date~,~VIN~,~Year~,~Make~,~Model~,~Model Number~,~Odometer~,~Exterior Color~,~Exterior Color Code~,~Interior Color~,~Interior Color Code~,~Trim~,~Transmission~,~Cylinder~,~Weight~,~Description~,~Vehicle Style~,~Engine~,~Fuel Type~,~MPG~,~Standard Equipment~,~Factory Accessory Code~,~Factory Accessory Description~,~Factory Accessory Cost~,~Factory Accessory Retail~,~Accessory Code~,~Accessory Description~,~Accessory Cost~,~Accessory Retail~,~Accessory Invoice~,~Package Code~,~Location~,~Certification~,~Certification Number~,~Sales Code~,~Wholesale~,~Accounting Make~,~Open RO Number~,~License Fee~,~Category~,~Invoice~,~Cost Pack~,~Cost~,~Holdback~,~List Price~,~MSRP~,~Internet Price~,~VIN Explosion Year~,~VIN Explosion Make~,~VIN Explosion Model~,~VIN Explosion Trim~,~VIN Explosion Tran Type~,~VIN Explosion Fuel Type~,~VIN Explosion Chrome ID~,~VIN Explosion Engine Size~,~VIN Explosion GVW Range~,~Image Location URL~,~Video Location URL~,~Image Modified Date~";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}