import re
regex = re.compile(r"(?P<delim>[^\w\n\"\'])(?P<space> ?)(?P<quote>[\"\'~]).*?(?P=quote)(?P=delim)")
test_str = "~File Type~,~DV Dealer ID~,~Delegate Dealer ID~,~DMS Type~,~Stock Number~,~Vehicle Type~,~Vehicle Status~,~Inventory Date~,~Purchase Date~,~Sold Date~,~VIN~,~Year~,~Make~,~Model~,~Model Number~,~Odometer~,~Exterior Color~,~Exterior Color Code~,~Interior Color~,~Interior Color Code~,~Trim~,~Transmission~,~Cylinder~,~Weight~,~Description~,~Vehicle Style~,~Engine~,~Fuel Type~,~MPG~,~Standard Equipment~,~Factory Accessory Code~,~Factory Accessory Description~,~Factory Accessory Cost~,~Factory Accessory Retail~,~Accessory Code~,~Accessory Description~,~Accessory Cost~,~Accessory Retail~,~Accessory Invoice~,~Package Code~,~Location~,~Certification~,~Certification Number~,~Sales Code~,~Wholesale~,~Accounting Make~,~Open RO Number~,~License Fee~,~Category~,~Invoice~,~Cost Pack~,~Cost~,~Holdback~,~List Price~,~MSRP~,~Internet Price~,~VIN Explosion Year~,~VIN Explosion Make~,~VIN Explosion Model~,~VIN Explosion Trim~,~VIN Explosion Tran Type~,~VIN Explosion Fuel Type~,~VIN Explosion Chrome ID~,~VIN Explosion Engine Size~,~VIN Explosion GVW Range~,~Image Location URL~,~Video Location URL~,~Image Modified Date~"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")