$re = '/[^\/#]+$/m';
$str = 'newURL: "http://localhost:8080/talk.html#AProblem
oldURL: "http://localhost:8080/talk.html#AProblem/MACHOs
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);