re = /[^\/#]+$/m
str = 'newURL: "http://localhost:8080/talk.html#AProblem
oldURL: "http://localhost:8080/talk.html#AProblem/MACHOs
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end