$re = '/^(?!0+$)[0-9]{1,10}$/m';
$str = '0
1
000
12
123
1234
12345
123456
1234567
12345678
123456789
1234567890
12345678901';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);