import re
regex = re.compile(r"^(?!0+$)[0-9]{1,10}$", flags=re.MULTILINE)
test_str = ("0\n"
"1\n"
"000\n"
"12\n"
"123\n"
"1234\n"
"12345\n"
"123456\n"
"1234567\n"
"12345678\n"
"123456789\n"
"1234567890\n"
"12345678901")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")