$re = '/^(?!.*(\d)\1{5}).*$/m';
$str = 'd111111
d11111
d999999
d12222222222
d99999
abchdjr12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);